Win7如何安装不兼容的VC++6.0(图文)

寡人今天写程序。可让人生气的是写的所有的程序没一个对的,不能连接运行。原来经过好多次的纠结后来才知道是win7不兼容导致的结果。多费解。好久才弄好。所以来发表个日志,希望有同样问题的孩子们可以试试。废话不说了,以下是正题:

运行setup.exe安装程序,会弹出如下的的程序兼容性助手提示:此程序存在已知的兼容性问题,这个是Win7在警告用户VC++6.0存在兼容性问题:此程序存在已知的兼容性问题。如下图,选中不再显示此消息,点“运行程序”。

之后再有遇到“此程序存在已知的兼容性问题”的提示时候,也按这个做法处理!

win7 vc++6.0不兼容安装

接着安装,进入选择安装类型这一步的时候,要注意。点“Custom”自定义安装类型

win7 vc++6.0不兼容安装

Custom自定义安装里,点中Tools组件,更改选项

win7 vc++6.0

把其中的OLE/Com Object Viewer取消,不选择:

win7 vc++6.0

再返回到组件选择的时候,Tools就变为灰色的勾了,因为里面我们取消了OLE/Com Object Viewer这一顶

win7 vc++6.0不兼容

:其他的就默认安装就可以了,要注意的上面已经都交代了,安装完成,出现安装成功的提示:

解决Win7安装vc++6.0不兼容问题

安装完成后,启动VC6的时候,也出现“此程序存在已知的兼容性问题”的提示,按上面第一步中的处理:选中不再显示此消息,点“运行程序”。搞定,哈哈。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

您可以使用这些HTML标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>